mirror of
https://github.com/authelia/authelia.git
synced 2026-10-28 09:34:52 +08:00
build(deps): update dependency react-i18next to v17.0.20 (#13512)
This PR contains the following updates: | Package | Change | [Age](https://docs.renovatebot.com/merge-confidence/) | [Confidence](https://docs.renovatebot.com/merge-confidence/) | |---|---|---|---| | [react-i18next](https://redirect.github.com/i18next/react-i18next) | [`17.0.19` → `17.0.20`](https://renovatebot.com/diffs/npm/react-i18next/17.0.19/17.0.20) |  |  | --- ### Release Notes <details> <summary>i18next/react-i18next (react-i18next)</summary> ### [`v17.0.20`](https://redirect.github.com/i18next/react-i18next/blob/HEAD/CHANGELOG.md#17020) [Compare Source](https://redirect.github.com/i18next/react-i18next/compare/v17.0.19...v17.0.20) - fix: `useTranslation` no longer suspends when a missing namespace is loaded by a synchronous backend. With `useSuspense` (the default), a namespace that wasn't in the store yet always made the component throw the loading promise, even when the backend had already delivered the resources while that promise was being created. React then showed the `Suspense` fallback and rendered again right away, which appears as a fallback flash (a white flash in React Native) and costs performance. The hook now starts the load first, checks the store again and only suspends if the namespace is still missing. This helps every backend that calls back synchronously, for example `i18next-resources-to-backend` with a static resources object or a loader that returns the data directly. Async backends, and an instance that isn't initialized yet, still suspend as before. Thanks [@​oblador](https://redirect.github.com/oblador) ([#​1937](https://redirect.github.com/i18next/react-i18next/pull/1937)). </details> --- ### Configuration 📅 **Schedule**: (UTC) - Branch creation - At any time (no schedule defined) - Automerge - At any time (no schedule defined) 🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied. ♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox. 🔕 **Ignore**: Close this PR and you won't be reminded about this update again. --- - [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box --- This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/authelia/authelia). <!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0NC4xNjQuMSIsInVwZGF0ZWRJblZlciI6IjQ0LjE2NC4xIiwidGFyZ2V0QnJhbmNoIjoibWFzdGVyIiwibGFiZWxzIjpbImRlcGVuZGVuY2llcyIsImphdmFzY3JpcHQiXX0=--> Co-authored-by: renovate[bot] <29139614+renovate[bot]@users.noreply.github.com>
This commit is contained in:
1 parent
1bce0eef7d
commit
fd0820fa3b
2 files changed
+6
-6
No files matched your search
+1
-1
@@ -21,7 +21,7 @@
|
||||
"qrcode.react": "4.2.0",
|
||||
"react": "19.3.1",
|
||||
"react-dom": "19.3.1",
|
||||
"react-i18next": "17.0.19",
|
||||
"react-i18next": "17.0.20",
|
||||
"react-router": "8.4.0",
|
||||
"zxcvbn": "4.4.2"
|
||||
},
|
||||
|
||||
Generated
+5
-5
@@ -59,8 +59,8 @@ importers:
|
||||
specifier: 19.3.1
|
||||
version: 19.3.1(react@19.3.1)
|
||||
react-i18next:
|
||||
specifier: 17.0.19
|
||||
version: 17.0.19(@typescript/typescript6@6.0.2)(i18next@26.4.7(@typescript/typescript6@6.0.2))(react-dom@19.3.1(react@19.3.1))(react@19.3.1)
|
||||
specifier: 17.0.20
|
||||
version: 17.0.20(@typescript/typescript6@6.0.2)(i18next@26.4.7(@typescript/typescript6@6.0.2))(react-dom@19.3.1(react@19.3.1))(react@19.3.1)
|
||||
react-router:
|
||||
specifier: 8.4.0
|
||||
version: 8.4.0(react-dom@19.3.1(react@19.3.1))(react@19.3.1)
|
||||
@@ -3365,8 +3365,8 @@ packages:
|
||||
peerDependencies:
|
||||
react: ^19.3.1
|
||||
|
||||
react-i18next@17.0.19:
|
||||
resolution: {integrity: sha512-BRHqiqOfW4J/LBVtbBFHoBoZm/Ez2/tkHPitYtn0CSpkYhEaEAsZMPsg7hZlomu30UJYQ6ZKiP3pwa3QnxGvQw==}
|
||||
react-i18next@17.0.20:
|
||||
resolution: {integrity: sha512-rzSSirf0NP9vfcUXHZAksIuyMWl7L/T/7nm8S+sSIFuIzku54qcyyVAOZXbawPNpUxGkDx/eosSv4DrpzcxuOQ==}
|
||||
peerDependencies:
|
||||
i18next: '>= 26.2.0'
|
||||
react: '>= 16.8.0'
|
||||
@@ -7258,7 +7258,7 @@ snapshots:
|
||||
react: 19.3.1
|
||||
scheduler: 0.28.0
|
||||
|
||||
react-i18next@17.0.19(@typescript/typescript6@6.0.2)(i18next@26.4.7(@typescript/typescript6@6.0.2))(react-dom@19.3.1(react@19.3.1))(react@19.3.1):
|
||||
react-i18next@17.0.20(@typescript/typescript6@6.0.2)(i18next@26.4.7(@typescript/typescript6@6.0.2))(react-dom@19.3.1(react@19.3.1))(react@19.3.1):
|
||||
dependencies:
|
||||
'@babel/runtime': 7.29.7
|
||||
html-parse-stringify: 4.0.1
|
||||
|
||||
Reference in new issue
Block a user