Files
Akihiro Suda 4b6d3e8da0 website: update hugo-extended (0.133.1 -> 0.164.0), docsy (0.11.0 -> 0.17.0)
- hugo-extended 0.133.1 -> 0.164.0 (via `npm run update:pkg:hugo`;
  0.164.0 is the latest on npm)
- docsy 0.11.0 -> 0.17.0, as docsy 0.11.0 is incompatible with
  Hugo >= 0.141 (Resource.Err removal):
  - The Hugo module path is now `github.com/google/docsy/theme`; the
    `github.com/google/docsy/dependencies` module is retired.
    Bootstrap and Font Awesome (now v7) come from npm instead, via
    `hugo mod npm pack` (packages/hugoautogen)
  - docsy 0.17 requires Dart Sass >= 1.95 (LibSass is no longer
    supported); add `sass-embedded` to devDependencies, which `npm run`
    puts on PATH for hugo (locally, on Netlify, and in CI)
- hugo.toml: allow HTML content files (`security.allowContent`,
  default-deny since Hugo 0.162) and Node.js parent-directory reads
  for PostCSS/browserslist (`security.node.permissions.allowRead`,
  sandboxed since Hugo 0.161)
- hugo.toml: rename deprecated `includeFiles` -> `files`,
  `languageName` -> `label`; bump min Hugo version to 0.162.0
- Refresh caniuse-lite via `npx update-browserslist-db`

Assisted-by: Claude Fable 5 <noreply@anthropic.com>
Signed-off-by: Akihiro Suda <akihiro.suda.cz@hco.ntt.co.jp>
2026-09-05 04:15:45 +09:00

16 lines
448 B
YAML

# THIS IS A TEST CONFIG ONLY!
# FOR THE CONFIGURATION OF YOUR SITE USE hugo.yaml.
#
# As of Docsy 0.7.0, Hugo 0.110.0 or later must be used.
#
# The sole purpose of this config file is to detect Hugo-module builds that use
# an older version of Hugo.
#
# DO NOT add any config parameters to this file. You can safely delete this file
# if your project is using the required Hugo version.
module:
hugoVersion:
extended: true
min: 0.162.0